$re = '/[\s\S]+/';
$str = 'AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);