using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]+";
string input = @"AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}