#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)\w{3}"
Local $sString = "11516798" & @CRLF & _
"11516000" & @CRLF & _
"98700000000"
Local $sSubst = "$1000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)