use strict;
my $str = '11516798
11516000
98700000000';
my $regex = qr/(.*)\w{3}/mp;
my $subst = '$1000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";