$re = '/(.*)\w{3}/m';
$str = '11516798
11516000
98700000000';
$subst = "$1000";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;