// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\w{3}").unwrap();
let string = "11516798
11516000
98700000000";
let substitution = "$1000";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}