import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "wp\\.i18n\\.setLocaleData\\(\\s*localeData,\\s*domain\\s*\\);\\s*\\}\\s*\\)\\s*\\(\\s*\"[^\"]+\",\\s*(.*)\\)\\s*;\\s*<\\/script>";
final String string = "<script type=\"text/javascript\" id=\"seopress-metabox-js-translations\">\n"
+ "( function( domain, translations ) {\n"
+ " /*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;\n"
+ " localeData[\"\"].domain = domain;*/\n"
+ " console.log(translations);\n"
+ " //wp.i18n.setLocaleData( localeData, domain );\n"
+ "} )( \"wp-seopress\", { \"test1\": \"https://www.youtube.com/watch?v=sT1KpjKbsTk\" } );\n"
+ "</script>\n\n"
+ "<script type=\"text/javascript\" id=\"seopress-metabox-js-translations\">\n"
+ "( function( domain, translations ) {\n"
+ " /*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;\n"
+ " localeData[\"\"].domain = domain;*/\n"
+ " console.log(translations);\n"
+ " //wp.i18n.setLocaleData( localeData, domain );\n"
+ "} )( \"wp-seopress\", { \"test1\": \"https://www.youtube.com/watch?v=sT1KpjKbsTk\", \"test2\": \"<iframe width=\\\"560\\\" height=\\\"315\\\" src=\\\"https://www.youtube.com/embed/2aeObDtptdE\\\" title=\\\"YouTube video player\\\" frameborder=\\\"0\\\" allow=\\\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\\\" allowfullscreen></iframe>\" } );\n"
+ "</script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}