$re = '/wp\.i18n\.setLocaleData\(\s*localeData,\s*domain\s*\);\s*}\s*\)\s*\(\s*"[^"]+",\s*(.*)\)\s*;\s*<\/script>/m';
$str = '<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk" } );
</script>
<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk", "test2": "<iframe width=\\"560\\" height=\\"315\\" src=\\"https://www.youtube.com/embed/2aeObDtptdE\\" title=\\"YouTube video player\\" frameborder=\\"0\\" allow=\\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\\" allowfullscreen></iframe>" } );
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);