#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^"\r?\n]*(?:"(?:[^"]*")+)?[^"\r?\n]*"
Local $sString = "Row 1 -> abc|hbd|hss" & @CRLF & _
"Row 2 -> abd|"shs " & @CRLF & _
" hshs"|jdjd" & @CRLF & _
"Row 3 -> hddn|hddd|sdjdd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")