re = /[^"\r?\n]*(?:"(?:[^"]*")+)?[^"\r?\n]*/m
str = 'Row 1 -> abc|hbd|hss
Row 2 -> abd|"shs
hshs"|jdjd
Row 3 -> hddn|hddd|sdjdd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end