$re = '/[^"\r?\n]*(?:"(?:[^"]*")+)?[^"\r?\n]*/m';
$str = 'Row 1 -> abc|hbd|hss
Row 2 -> abd|"shs
hshs"|jdjd
Row 3 -> hddn|hddd|sdjdd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);