// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[^"\r?\n]*(?:"(?:[^"]*")+)?[^"\r?\n]*"#).unwrap();
let string = "Row 1 -> abc|hbd|hss
Row 2 -> abd|\"shs
hshs\"|jdjd
Row 3 -> hddn|hddd|sdjdd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}