using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""\r?\n]*(?:""(?:[^""]*"")+)?[^""\r?\n]*";
string input = @"Row 1 -> abc|hbd|hss
Row 2 -> abd|""shs
hshs""|jdjd
Row 3 -> hddn|hddd|sdjdd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}