#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/(\/[\w\.]+)+( *(;|,) *https:\/(\/[\w\.]+)+)+"
Local $sString = "https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3" & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3" & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1; https://hello.com.com/example2 , https://hello.com.com/example3 ; https://hello.com.com/example4" & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1;,https://hello.com.com/example2,https://hello.com.com/example3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")