re = /^https:\/(\/[\w\.]+)+( *(;|,) *https:\/(\/[\w\.]+)+)+/m
str = 'https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 , https://hello.com.com/example3 ; https://hello.com.com/example4
https://hello.com/example1;,https://hello.com.com/example2,https://hello.com.com/example3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end