// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/(\/[\w\.]+)+( *(;|,) *https:\/(\/[\w\.]+)+)+").unwrap();
let string = "https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 , https://hello.com.com/example3 ; https://hello.com.com/example4
https://hello.com/example1;,https://hello.com.com/example2,https://hello.com.com/example3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}