import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/(\\/[\\w\\.]+)+( *(;|,) *https:\\/(\\/[\\w\\.]+)+)+";
final String string = "https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3\n\n"
+ "https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3\n\n"
+ "https://hello.com/example1; https://hello.com.com/example2 , https://hello.com.com/example3 ; https://hello.com.com/example4\n\n"
+ "https://hello.com/example1;,https://hello.com.com/example2,https://hello.com.com/example3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}