package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/(\/[\w\.]+)+( *(;|,) *https:\/(\/[\w\.]+)+)+`)
var str = `https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3
https://hello.com/example1; https://hello.com.com/example2 , https://hello.com.com/example3 ; https://hello.com.com/example4
https://hello.com/example1;,https://hello.com.com/example2,https://hello.com.com/example3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}