#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\W)"
Local $sString = "December 2019 drop-ship" & @CRLF & _
"December 2019 __drop-shipdasf" & @CRLF & _
"December 2019 G##@$RFEdrop-ship()*(&" & @CRLF & _
"December 2019 G##@$RFEdropship()*(&- .csv" & @CRLF & _
"OO%2BFeb%2B2020%2BRedstone%2B65807%2B-%2BOO%2BOctober%2B2019%2B%25281%2529 .csv" & @CRLF & _
"" & @CRLF & _
"//" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")