using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\W)";
string input = @"December 2019 drop-ship
December 2019 __drop-shipdasf
December 2019 G##@$RFEdrop-ship()*(&
December 2019 G##@$RFEdropship()*(&- .csv
OO%2BFeb%2B2020%2BRedstone%2B65807%2B-%2BOO%2BOctober%2B2019%2B%25281%2529 .csv
//
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}