const regex = /(\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\W)', 'gm')
const str = `December 2019 drop-ship
December 2019 __drop-shipdasf
December 2019 G##@\$RFEdrop-ship()*(&
December 2019 G##@\$RFEdropship()*(&- .csv
OO%2BFeb%2B2020%2BRedstone%2B65807%2B-%2BOO%2BOctober%2B2019%2B%25281%2529 .csv
//
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}