use strict;
my $str = 'December 2019 drop-ship
December 2019 __drop-shipdasf
December 2019 G##@$RFEdrop-ship()*(&
December 2019 G##@$RFEdropship()*(&- .csv
OO%2BFeb%2B2020%2BRedstone%2B65807%2B-%2BOO%2BOctober%2B2019%2B%25281%2529 .csv
//
';
my $regex = qr/(\W)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}