re = /(\W)/m
str = 'December 2019 drop-ship
December 2019 __drop-shipdasf
December 2019 G##@$RFEdrop-ship()*(&
December 2019 G##@$RFEdropship()*(&- .csv
OO%2BFeb%2B2020%2BRedstone%2B65807%2B-%2BOO%2BOctober%2B2019%2B%25281%2529 .csv
//
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end