using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'\s*\+\s*'";
string substitution = @"";
string input = @" 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' + 'D isnull and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}