$re = '/\'\s*\+\s*\'/ms';
$str = ' \'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' + \'D isnull and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;