use strict;
my $str = ' \'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' + \'D isnull and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')';
my $regex = qr/'\s*\+\s*'/msp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";