re = /'\s*\+\s*'/m
str = ' \'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' + \'D isnull and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result