#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+\s[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+(-[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+)*$"
Local $sString = "Glaksdjfls Hhkasjd-Dhhhhhf" & @CRLF & _
"Mikael Shumaher" & @CRLF & _
"Maciek Porębski" & @CRLF & _
"Nasery Nawana-Djątrę"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")