package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+\s[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+(-[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+)*$`)
var str = `Glaksdjfls Hhkasjd-Dhhhhhf
Mikael Shumaher
Maciek Porębski
Nasery Nawana-Djątrę`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}