// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+\s[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+(-[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+)*$").unwrap();
let string = "Glaksdjfls Hhkasjd-Dhhhhhf
Mikael Shumaher
Maciek Porębski
Nasery Nawana-Djątrę";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}