re = /^[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+\s[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+(-[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+)*$/m
str = 'Glaksdjfls Hhkasjd-Dhhhhhf
Mikael Shumaher
Maciek Porębski
Nasery Nawana-Djątrę'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end