import Foundation
let pattern = #"^[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+\s[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+(-[A-Z][a-z,ą,ż,ś,ź,ę,ć,ń,ó,ł]+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Glaksdjfls Hhkasjd-Dhhhhhf
Mikael Shumaher
Maciek Porębski
Nasery Nawana-Djątrę
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)