#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^*]*(?:\*{2}[^ ][^*]*[^ ]\*{2}[^*\n]*)*(?:\*{2}(?: [^*]+|[^*]+ )\*{2}).*$"
Local $sString = "**correct** This line is **correct** and **properly marked down**." & @CRLF & _
"But this line **is not** because ** the second bold is wrong**." & @CRLF & _
"** Also** **This Also** ** This Also ** this line is wrong **even though this is right **." & @CRLF & _
"Absolutely no bold tagging in this sentence." & @CRLF & _
"**correct** This line is **correct** and **properly marked down**." & @CRLF & _
"But this line **is not** because ** the second bold is wrong**." & @CRLF & _
"** Also** **This Also** ** This Also ** this line is wrong **even though this is right **."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")