import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^*]*(?:\\*{2}[^ ][^*]*[^ ]\\*{2}[^*\\n]*)*(?:\\*{2}(?: [^*]+|[^*]+ )\\*{2}).*$";
final String string = "**correct** This line is **correct** and **properly marked down**.\n"
+ "But this line **is not** because ** the second bold is wrong**.\n"
+ "** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.\n"
+ "Absolutely no bold tagging in this sentence.\n"
+ "**correct** This line is **correct** and **properly marked down**.\n"
+ "But this line **is not** because ** the second bold is wrong**.\n"
+ "** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}