const regex = /^[^*]*(?:\*{2}[^ ][^*]*[^ ]\*{2}[^*\n]*)*(?:\*{2}(?: [^*]+|[^*]+ )\*{2}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^*]*(?:\\*{2}[^ ][^*]*[^ ]\\*{2}[^*\\n]*)*(?:\\*{2}(?: [^*]+|[^*]+ )\\*{2}).*$', 'gm')
const str = `**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.
Absolutely no bold tagging in this sentence.
**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}