package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^*]*(?:\*{2}[^ ][^*]*[^ ]\*{2}[^*\n]*)*(?:\*{2}(?: [^*]+|[^*]+ )\*{2}).*$`)
var str = `**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.
Absolutely no bold tagging in this sentence.
**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}