import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!(SUPER|POWER)\\s)(?<!(SHOP|XTRA|TOWN|PICK)\\s)(?<!(BIG|TOP|MAX)\\s)(?<!NU\\s)(?<!U\\s)SAVE\\s?(SUPERMARKET|HYPER)\\b";
final String string = "BIG SAVE SUPERMARKET HERE and SAVE HYPER";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}