re = /\b(?<!(SUPER|POWER)\s)(?<!(SHOP|XTRA|TOWN|PICK)\s)(?<!(BIG|TOP|MAX)\s)(?<!NU\s)(?<!U\s)SAVE\s?(SUPERMARKET|HYPER)\b/m
str = 'BIG SAVE SUPERMARKET HERE and SAVE HYPER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end