$re = '/\b(?<!(SUPER|POWER)\s)(?<!(SHOP|XTRA|TOWN|PICK)\s)(?<!(BIG|TOP|MAX)\s)(?<!NU\s)(?<!U\s)SAVE\s?(SUPERMARKET|HYPER)\b/m';
$str = 'BIG SAVE SUPERMARKET HERE and SAVE HYPER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);