use strict;
my $str = 'BIG SAVE SUPERMARKET HERE and SAVE HYPER';
my $regex = qr/\b(?<!(SUPER|POWER)\s)(?<!(SHOP|XTRA|TOWN|PICK)\s)(?<!(BIG|TOP|MAX)\s)(?<!NU\s)(?<!U\s)SAVE\s?(SUPERMARKET|HYPER)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}