using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]:[^:]*):(\d+):(\d+):(.*)|(\/[^:]*):(\d+):(\d+):(.*)";
string input = @"CssSyntaxError: /Users/nik/code/newb-for pr to McNerdius/App.css:17:1: Unexpected }
CssSyntaxError: E:\My Documents \App.css:17:1: Unexpected }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}