import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]:[^:]*):(\\d+):(\\d+):(.*)|(\\/[^:]*):(\\d+):(\\d+):(.*)";
final String string = "CssSyntaxError: /Users/nik/code/newb-for pr to McNerdius/App.css:17:1: Unexpected }\n"
+ "CssSyntaxError: E:\\My Documents \\App.css:17:1: Unexpected }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}