// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]:[^:]*):(\d+):(\d+):(.*)|(\/[^:]*):(\d+):(\d+):(.*)").unwrap();
let string = "CssSyntaxError: /Users/nik/code/newb-for pr to McNerdius/App.css:17:1: Unexpected }
CssSyntaxError: E:\\My Documents \\App.css:17:1: Unexpected }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}