const regex = /([A-Z]:[^:]*):(\d+):(\d+):(.*)|(\/[^:]*):(\d+):(\d+):(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]:[^:]*):(\\d+):(\\d+):(.*)|(\\\/[^:]*):(\\d+):(\\d+):(.*)', 'gm')
const str = `CssSyntaxError: /Users/nik/code/newb-for pr to McNerdius/App.css:17:1: Unexpected }
CssSyntaxError: E:\\My Documents \\App.css:17:1: Unexpected }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}