re = /([A-Z]:[^:]*):(\d+):(\d+):(.*)|(\/[^:]*):(\d+):(\d+):(.*)/m
str = 'CssSyntaxError: /Users/nik/code/newb-for pr to McNerdius/App.css:17:1: Unexpected }
CssSyntaxError: E:\\My Documents \\App.css:17:1: Unexpected }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end