# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z])(?!$)/\1,/g;t' <<< "ABC
-ABC
AB-C"