const regex = new RegExp('([A-Z])(?!$)', 'g')
const str = `ABC
-ABC
AB-C`;
const subst = `\1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);