#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([A-Z])(?!$)"
Local $sString = "ABC" & @CRLF & _
"-ABC" & @CRLF & _
"AB-C"
Local $sSubst = "\1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)