use strict;
my $str = 'ABC
-ABC
AB-C';
my $regex = qr/([A-Z])(?!$)/p;
my $subst = '\\1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";