import re
regex = re.compile(r"([A-Z])(?!$)")
test_str = ("ABC\n"
"-ABC\n"
"AB-C")
subst = "\\1,"
result = regex.sub(subst, test_str)
if result:
print(result)